using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?:ri)?comprat)[aeio]\b";
string substitution = @"\1+";
string input = @"ricomprate uno comprato comprata due comprate ricomprate tre ricomprato comprati";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}