const regex = /\b((?:ri)?comprat)[aeio]\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((?:ri)?comprat)[aeio]\\b', 'gm')
const str = `ricomprate uno comprato comprata due comprate ricomprate tre ricomprato comprati`;
const subst = `\1+`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);