// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b((?:ri)?comprat)[aeio]\b").unwrap();
let string = "ricomprate uno comprato comprata due comprate ricomprate tre ricomprato comprati";
let substitution = "\\1+";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}