use strict;
my $str = 'ricomprate uno comprato comprata due comprate ricomprate tre ricomprato comprati';
my $regex = qr/\b((?:ri)?comprat)[aeio]\b/mp;
my $subst = '\\1+';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";