package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b((?:ri)?comprat)[aeio]\b`)
var str = `ricomprate uno comprato comprata due comprate ricomprate tre ricomprato comprati`
var substitution = "\1+"
fmt.Println(re.ReplaceAllString(str, substitution))
}