using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S*(?:[Ss]mall|[Ll]arge|[Mm]edium|Med[.])\S*)";
string input = @"some text Small some text""
2 ""some text small-med some text""
3 ""some text Med. some text""
4 ""some text medium some text""
5 ""some text med-large some text""
6 ""some text large some text";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}