import re
regex = re.compile(r"(\S*(?:[Ss]mall|[Ll]arge|[Mm]edium|Med[.])\S*)")
test_str = ("some text Small some text\" \n"
"2 \"some text small-med some text\"\n"
"3 \"some text Med. some text\" \n"
"4 \"some text medium some text\" \n"
"5 \"some text med-large some text\" \n"
"6 \"some text large some text")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")