const regex = /(\S*(?:[Ss]mall|[Ll]arge|[Mm]edium|Med[.])\S*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S*(?:[Ss]mall|[Ll]arge|[Mm]edium|Med[.])\\S*)', 'g')
const str = `some text Small some text"
2 "some text small-med some text"
3 "some text Med. some text"
4 "some text medium some text"
5 "some text med-large some text"
6 "some text large some text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}