package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\S*(?:[Ss]mall|[Ll]arge|[Mm]edium|Med[.])\S*)`)
var str = `some text Small some text"
2 "some text small-med some text"
3 "some text Med. some text"
4 "some text medium some text"
5 "some text med-large some text"
6 "some text large some text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}