re = /(\S*(?:[Ss]mall|[Ll]arge|[Mm]edium|Med[.])\S*)/
str = 'some text Small some text"
2 "some text small-med some text"
3 "some text Med. some text"
4 "some text medium some text"
5 "some text med-large some text"
6 "some text large some text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end