# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\d+)th Doctor)(\/| & )(.*)/\g<4>\g<3>\g<1>/gm;t' <<< "9th Doctor & Rose Tyler
9th Doctor & Rose Tyler & Jack Harkness
9th Doctor/Rose Tyler
10th Doctor/Rose Tyler"