#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((\d+)th Doctor)(/| & )(.*)"
Local $sString = "9th Doctor & Rose Tyler" & @CRLF & _
"9th Doctor & Rose Tyler & Jack Harkness" & @CRLF & _
"9th Doctor/Rose Tyler" & @CRLF & _
"10th Doctor/Rose Tyler"
Local $sSubst = "\g<4>\g<3>\g<1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)