$re = '/((\d+)th Doctor)(/| & )(.*)/m';
$str = '9th Doctor & Rose Tyler
9th Doctor & Rose Tyler & Jack Harkness
9th Doctor/Rose Tyler
10th Doctor/Rose Tyler';
$subst = "\g<4>\g<3>\g<1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;