using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d+)th Doctor)(/| & )(.*)";
string substitution = @"\g<4>\g<3>\g<1>";
string input = @"9th Doctor & Rose Tyler
9th Doctor & Rose Tyler & Jack Harkness
9th Doctor/Rose Tyler
10th Doctor/Rose Tyler";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}