package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((\d+)th Doctor)(/| & )(.*)`)
var str = `9th Doctor & Rose Tyler
9th Doctor & Rose Tyler & Jack Harkness
9th Doctor/Rose Tyler
10th Doctor/Rose Tyler`
var substitution = "\g<4>\g<3>\g<1>"
fmt.Println(re.ReplaceAllString(str, substitution))
}