use strict;
my $str = '9th Doctor & Rose Tyler
9th Doctor & Rose Tyler & Jack Harkness
9th Doctor/Rose Tyler
10th Doctor/Rose Tyler';
my $regex = qr/((\d+)th Doctor)(/| & )(.*)/mp;
my $subst = '\\g<4>\\g<3>\\g<1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";