// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((\d+)th Doctor)(/| & )(.*)").unwrap();
let string = "9th Doctor & Rose Tyler
9th Doctor & Rose Tyler & Jack Harkness
9th Doctor/Rose Tyler
10th Doctor/Rose Tyler";
let substitution = "\\g<4>\\g<3>\\g<1>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}