package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)-\d+x\d+\.jpg`)
var str = `101018-202x300.jpg 100116-215x300.jpg 1000748-300x157.jpg 100138-196x300.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}