import re
regex = re.compile(r"(\d+)-\d+x\d+\.jpg")
test_str = "101018-202x300.jpg 100116-215x300.jpg 1000748-300x157.jpg 100138-196x300.jpg"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")