import Foundation
let pattern = #"(\d+)-\d+x\d+\.jpg"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"101018-202x300.jpg 100116-215x300.jpg 1000748-300x157.jpg 100138-196x300.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)