$re = '/(\d+)-\d+x\d+\.jpg/';
$str = '101018-202x300.jpg 100116-215x300.jpg 1000748-300x157.jpg 100138-196x300.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);