const regex = /(\d+)-\d+x\d+\.jpg/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)-\\d+x\\d+\\.jpg', 'g')
const str = `101018-202x300.jpg 100116-215x300.jpg 1000748-300x157.jpg 100138-196x300.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}