use strict;
my $str = '101018-202x300.jpg 100116-215x300.jpg 1000748-300x157.jpg 100138-196x300.jpg';
my $regex = qr/(\d+)-\d+x\d+\.jpg/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}