re = /(\d+)-\d+x\d+\.jpg/
str = '101018-202x300.jpg 100116-215x300.jpg 1000748-300x157.jpg 100138-196x300.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end