# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\?pg=([0-9]+)/page\1.html/g;t' <<< "<a href=\"/?pg=2\">test</a>
<a href=\"/?pg=999\">another</a>"