use strict;
my $str = '<a href="/?pg=2">test</a>
<a href="/?pg=999">another</a>';
my $regex = qr/\?pg=([0-9]+)/p;
my $subst = 'page\\1.html';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";