$re = '/\?pg=([0-9]+)/';
$str = '<a href="/?pg=2">test</a>
<a href="/?pg=999">another</a>';
$subst = "page\1.html";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;