#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\?pg=([0-9]+)"
Local $sString = "<a href="/?pg=2">test</a>" & @CRLF & _
"<a href="/?pg=999">another</a>"
Local $sSubst = "page\1.html"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)