// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\?pg=([0-9]+)").unwrap();
let string = "<a href=\"/?pg=2\">test</a>
<a href=\"/?pg=999\">another</a>";
let substitution = "page\\1.html";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}