package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\?pg=([0-9]+)`)
var str = `<a href="/?pg=2">test</a>
<a href="/?pg=999">another</a>`
var substitution = "page\1.html"
fmt.Println(re.ReplaceAllString(str, substitution))
}