const regex = /\?pg=([0-9]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\?pg=([0-9]+)', 'g')
const str = `<a href="/?pg=2">test</a>
<a href="/?pg=999">another</a>`;
const subst = `page\1.html`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);