import Foundation
let pattern = #"\?pg=([0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a href="/?pg=2">test</a>
<a href="/?pg=999">another</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"page\1.html"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)