#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "get_option\((.[^)]*)\)"
Local $sString = "if(get_option($id,'')==$o){$selected='selected';}" & @CRLF & _
"stripslashes(get_option(aaa))" & @CRLF & _
"get_option(bbb)" & @CRLF & _
"get_option(ccc)" & @CRLF & _
"get_option(ddd)" & @CRLF & _
"get_option(eee)" & @CRLF & _
"get_option(fff)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")