re = /get_option\((.[^)]*)\)/
str = 'if(get_option($id,\'\')==$o){$selected=\'selected\';}
stripslashes(get_option(aaa))
get_option(bbb)
get_option(ccc)
get_option(ddd)
get_option(eee)
get_option(fff)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end