// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"get_option\((.[^)]*)\)").unwrap();
let string = "if(get_option($id,'')==$o){$selected='selected';}
stripslashes(get_option(aaa))
get_option(bbb)
get_option(ccc)
get_option(ddd)
get_option(eee)
get_option(fff)";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}