$re = '/get_option\((.[^)]*)\)/';
$str = 'if(get_option($id,\'\')==$o){$selected=\'selected\';}
stripslashes(get_option(aaa))
get_option(bbb)
get_option(ccc)
get_option(ddd)
get_option(eee)
get_option(fff)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);