import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "get_option\\((.[^)]*)\\)";
final String string = "if(get_option($id,'')==$o){$selected='selected';}\n"
+ "stripslashes(get_option(aaa))\n"
+ "get_option(bbb)\n"
+ "get_option(ccc)\n"
+ "get_option(ddd)\n"
+ "get_option(eee)\n"
+ "get_option(fff)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}