import Foundation
let pattern = #"get_option\((.[^)]*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
if(get_option($id,'')==$o){$selected='selected';}
stripslashes(get_option(aaa))
get_option(bbb)
get_option(ccc)
get_option(ddd)
get_option(eee)
get_option(fff)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}