use strict;
my $str = 'if(get_option($id,\'\')==$o){$selected=\'selected\';}
stripslashes(get_option(aaa))
get_option(bbb)
get_option(ccc)
get_option(ddd)
get_option(eee)
get_option(fff)';
my $regex = qr/get_option\((.[^)]*)\)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}