#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([[:alpha:]]+:\/\/.+?[?&]mod=)(.+?)(:.+)"
Local $sString = "Example: LINK: http://l.corp.help.com/help/me.php?mod=jp_james:thank you" & @CRLF & _
"" & @CRLF & _
"http://l.corp.help.com/help/me.php?mod=jp_james:thank you" & @CRLF & _
"" & @CRLF & _
"http://l.corp.help.com/help/me.php?type=testmod=jp_james:thank you" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")