import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([[:alpha:]]+:\\/\\/.+?[?&]mod=)(.+?)(:.+)";
final String string = "Example: LINK: http://l.corp.help.com/help/me.php?mod=jp_james:thank you\n\n"
+ "http://l.corp.help.com/help/me.php?mod=jp_james:thank you\n\n"
+ "http://l.corp.help.com/help/me.php?type=testmod=jp_james:thank you\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}