const regex = /^([[:alpha:]]+:\/\/.+?[?&]mod=)(.+?)(:.+)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([[:alpha:]]+:\\\/\\\/.+?[?&]mod=)(.+?)(:.+)', 'm')
const str = `Example: LINK: http://l.corp.help.com/help/me.php?mod=jp_james:thank you
http://l.corp.help.com/help/me.php?mod=jp_james:thank you
http://l.corp.help.com/help/me.php?type=testmod=jp_james:thank you
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}