re = /^([[:alpha:]]+:\/\/.+?[?&]mod=)(.+?)(:.+)/m
str = 'Example: LINK: http://l.corp.help.com/help/me.php?mod=jp_james:thank you
http://l.corp.help.com/help/me.php?mod=jp_james:thank you
http://l.corp.help.com/help/me.php?type=testmod=jp_james:thank you
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end