use strict;
my $str = 'Example: LINK: http://l.corp.help.com/help/me.php?mod=jp_james:thank you
http://l.corp.help.com/help/me.php?mod=jp_james:thank you
http://l.corp.help.com/help/me.php?type=testmod=jp_james:thank you
';
my $regex = qr/^([[:alpha:]]+:\/\/.+?[?&]mod=)(.+?)(:.+)/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}