import re
regex = re.compile(r"^([[:alpha:]]+:\/\/.+?[?&]mod=)(.+?)(:.+)", flags=re.MULTILINE)
test_str = ("Example: LINK: http://l.corp.help.com/help/me.php?mod=jp_james:thank you\n\n"
"http://l.corp.help.com/help/me.php?mod=jp_james:thank you\n\n"
"http://l.corp.help.com/help/me.php?type=testmod=jp_james:thank you\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")