package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([[:alpha:]]+:\/\/.+?[?&]mod=)(.+?)(:.+)`)
var str = `Example: LINK: http://l.corp.help.com/help/me.php?mod=jp_james:thank you
http://l.corp.help.com/help/me.php?mod=jp_james:thank you
http://l.corp.help.com/help/me.php?type=testmod=jp_james:thank you
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}