#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:(?:(?:Miss|Mr|Lady|Mrs|Ms|Dr|Sir)\b|Mr\.)\s+)?(\S+)"
Local $sString = "Mrs Daksha Karsan" & @CRLF & _
"Mr Shane Kyle Taylor" & @CRLF & _
"Mr Ahmed Demerdash Keyani" & @CRLF & _
"Perry Joe Wilson" & @CRLF & _
"Miss Chantelle Reece" & @CRLF & _
"Mike Stewart" & @CRLF & _
"Dr Ariel Verun Patel" & @CRLF & _
"Mr John Sim" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)