const regex = new RegExp('^(?:(?:(?:Miss|Mr|Lady|Mrs|Ms|Dr|Sir)\\b|Mr\\.)\\s+)?(\\S+)', 'gm')
const str = `Mrs Daksha Karsan
Mr Shane Kyle Taylor
Mr Ahmed Demerdash Keyani
Perry Joe Wilson
Miss Chantelle Reece
Mike Stewart
Dr Ariel Verun Patel
Mr John Sim
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);