import Foundation
let pattern = #"^(?:(?:(?:Miss|Mr|Lady|Mrs|Ms|Dr|Sir)\b|Mr\.)\s+)?(\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Mrs Daksha Karsan
Mr Shane Kyle Taylor
Mr Ahmed Demerdash Keyani
Perry Joe Wilson
Miss Chantelle Reece
Mike Stewart
Dr Ariel Verun Patel
Mr John Sim
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)