package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:(?:Miss|Mr|Lady|Mrs|Ms|Dr|Sir)\b|Mr\.)\s+)?(\S+)`)
var str = `Mrs Daksha Karsan
Mr Shane Kyle Taylor
Mr Ahmed Demerdash Keyani
Perry Joe Wilson
Miss Chantelle Reece
Mike Stewart
Dr Ariel Verun Patel
Mr John Sim
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}